Summary
CVE-2026-119977 is a Time-of-check Time-of-use (TOCTOU) race condition (CWE-367) in WordPress Core that can lead to remote code execution. It affects WordPress versions 4.7 through 7.1.3 and is rated High severity (CVSS 8.1). An unauthenticated attacker can exploit it during the core upgrade window.
Technical details
- Root cause: predictable, web-accessible staging paths are used during full-package core upgrades (the CVE record references
class-wp-upgrader.php,class-core-upgrader.php,update-core.phpandsetup-config.php). - Trigger conditions: the attack works only while a full-package core upgrade is running. This timing requirement is reflected in the high attack complexity (AC:H) of the CVSS vector.
- Attack vector: network, with no authentication and no user interaction.
- Impact: code execution on the server, with high impact to confidentiality, integrity and availability.
- Credit: reported by Umut Bayram. The CVE record lists a disclosure date of October 28, 2026.
Affected software
- WordPress Core 4.7.0 through 7.1.3. The CVE record lists affected branches including 4.7.0–4.7.38, 5.0.0–5.0.30, 6.0.0–6.0.17, 6.9.0–6.9.10 and 7.0.0–7.1.3.
Severity
- CVSS v3.1 base score 8.1 (High):
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Mitigation and recommended actions
- Immediate: upgrade to WordPress 7.1.4, or to the latest security release for your branch. The WordPress 7.1.4 security release addresses this issue.
- Check that automatic background updates are enabled, or update through Dashboard → Updates.
- If you can’t patch immediately: restrict external web access to
wp-content/upgrade/at the web server or WAF, and avoid running core upgrades while the site is publicly reachable. These are general hardening steps and are not listed in the CVE record.

