Summary
CVE-2026-63146 is a critical code injection vulnerability (CWE-94) in Omnispace Agora Project that can lead to unauthenticated remote code execution. All versions before 26.10.0 are affected. The CVSS v4.0 base score is 9.3 (Critical).
Technical details
- Root cause: Unescaped, attacker-controlled values are written into the
config.inc.phpconfiguration file during installation, throughFile::updateConfigFile()andDbInstall::dbControl(). - Contributing flaw: An SQL injection issue is enabled by
PDO::ATTR_EMULATE_PREPARES, which supports stacked queries. - Attack vector: Network, with no authentication or user interaction. An attacker uses the SQL injection to re-trigger the installer, then injects PHP code into the configuration file.
- Impact: Arbitrary PHP code execution on the underlying server, which compromises confidentiality, integrity and availability.
Affected software
- Omnispace Agora Project: all versions before 26.10.0
Severity
- CVSS v4.0: 9.3 (Critical),
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N - CVSS v3.1: 9.8 (Critical),
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Mitigation and recommended actions
- Immediate: upgrade Agora Project to version 26.10.0 or later.
- Review
config.inc.phpfor unexpected or injected PHP code, and investigate any instance that was exposed to the internet while running an affected version. - If you cannot patch right away, restrict network access to the affected instance.

