Summary
CVE-2026-97229 is a critical remote code execution vulnerability in GitLab, classified as CWE-190 (Integer Overflow or Wraparound). Under certain conditions, an unauthenticated user could execute arbitrary code on the GitLab server using a specially crafted regular expression in a CI/CD configuration. It has a CVSS v3.1 base score of 10.0 (Critical).
Technical details
- Root cause: insufficient regular expression validation (CWE-190, Integer Overflow or Wraparound).
- Trigger conditions: "certain conditions", which the CVE record does not detail, and a specially crafted regular expression in a CI/CD configuration.
- Attack vector: network, with no privileges required and no user interaction.
- Impact: arbitrary code execution on the GitLab server. The CVSS scope is changed, and confidentiality, integrity and availability impact are all rated high.
Affected software
- GitLab 19.2 versions before 19.2.8
- GitLab 19.3 versions before 19.3.5
- GitLab 19.4 versions before 19.4.2
Severity
- CVSS v3.1 base score: 10.0 (Critical)
- Vector:
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
Mitigation and recommended actions
- Immediate: upgrade to GitLab 19.2.8, 19.3.5, 19.4.2 or later, according to your release line.
- The sources reviewed do not describe any workaround. Until patching is complete, restrict network access to affected instances where possible.

